[Ilugc] Resolution problem with Arch Linux and Xfce

Ashok Gautham thescriptdevil at gmail.com
Mon Dec 15 21:51:32 IST 2008


On Mon, Dec 15, 2008 at 8:35 AM, Bhargav Prasanna <bhargavprasanna at gmail.com
> wrote:

>
> After a lot of speculation, i went for Xfce.. As i had used it before
> (in Xubuntu), i thought i'd feel comfortable..
> Dint work.. so i edited the second line of the .xinitrc file.. then
> gave 'startxfce4' at the prompt..
> It worked!!

/me points out that it must be exec xfce4-session in .xinitrc and not
startxfce4.

But the resolution was darn low.. 640x480 i guess..
> I've edited the "Screen" section in my xorg.conf numerous times after
> that.. deleted all Mode entries except "1024x768" (the resolution i
> want) but ecerytime i login, i get only a 640x480 screen.. Xfce
> overrides the xorg.conf file specs..

If you initiate xfce4 through xinit (or startx for that matter), the
resolution
will be taken from the default xorg.conf. Else xfce will figure out its own
resolution. (Like you did in your case using startxfce4)


> The CLI where i give the startxfce4 command (which happens to be vc/1
> or vc/2 et. al.) has a good resolution though!

Hmmm. That is dependent on the way grub's menu.lst is configured
#  FRAMEBUFFER RESOLUTION SETTINGS
#     +-------------------------------------------------+
#          | 640x480    800x600    1024x768   1280x1024
#      ----+--------------------------------------------
#      256 | 0x301=769  0x303=771  0x305=773   0x307=775
#      32K | 0x310=784  0x313=787  0x316=790   0x319=793
#      64K | 0x311=785  0x314=788  0x317=791   0x31A=794
#      16M | 0x312=786  0x315=789  0x318=792   0x31B=795
#     +-------------------------------------------------+

A happy Archer,

Ashok `ScriptDevil` Gautham


More information about the ilugc mailing list