[Ilugc] Re: tata Indicom usb modem internet

Ashish Verma ashishverma1984 at gmail.com
Tue Dec 23 13:42:24 IST 2008


On Tue, Dec 23, 2008 at 1:15 PM, Satish Eerpini <eerpini at gmail.com> wrote:

> How did you set it up ?
>  >>
> >> Padhu,
> >> Ooty.
>

Hi,

Below is what all I did.

1) Inserted the Modem
2) Using the relevant output from /proc/bus/usb/devices I ran the below
command:

#modprobe usbserial vendor=*0x*1b7d product=*0x*070a

2) Ran the wvdialconf command. This generated a /etc/wvdial.conf file

My wvdial.conf file looks like below I added a parameter or two from the
internet:

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = USB Modem
Phone = #777
ISDN = 0
Username = internet
Password = internet
Modem = /dev/ttyACM0
Baud = 460800
; SetVolume = 0
; FlowControl = Hardware (CRTSCTS)
; Dial Command = ATDT
Stupid Mode = 1

3) My #lsmod |grep -i usb output is as below:

usbserial              40272  0
hci_usb                23068  2
bluetooth              59044  8 bnep,rfcomm,l2cap,hci_usb

*I am not sure whether it is a must or not, but I removed the usb_storage
module because per the internet, It creates conflicts on the device or
something like that.

4) Since I had other netwok devices setup too, my "route -n" showed that
access to 0.0.0.0 be made via my bridge device kbr0. So I deleted that entry
and made another one indicating that 0.0.0.0 be access via ppp0 device.

5) I ran the wvdial command and my device started to work. I got an IP and
DNS IPs. I also added the opendns IPs to the resolv.conf file.

Note: I do not use the NetworkManager service instead I use the network
service. I guess the NM service automates most of the things. Since it is
changes some of the setting by itself, I do not use it.

Regards,
Ashish


More information about the ilugc mailing list