[Ilugc] Issue in ubuntu server installtion version 15.10

Arun Khan knura9 at gmail.com
Tue Dec 1 10:26:34 IST 2015


On Mon, Nov 30, 2015 at 7:44 PM, Shakthi Kannan <shakthimaan at gmail.com> wrote:
> Hi,
>
> --- On Mon, Nov 30, 2015 at 7:38 PM, Sundar Raj <msrarun22 at gmail.com> wrote:
> | Facing some problem in ubuntu .Installed O/s but now i could not
> | install additional packages , GUI, etc...
> | When i try to install rpm using the following command it says the following
> | error.
> |
> | sudo apt-get install rpm
> \--
>
> Ubuntu is a Debian-based distribution, and it uses apt as its package
> manager, while RPM-based distributions use rpm.
>
> Why do you want to install rpm in Ubuntu?
>

The RPM tool set  is available as a deb package.   It is useful to
have it on a Debian based system to examine RPM based packages.

I would not recommend installing RPM application/library packages on a
DEB based system using the RPM tools.

In fact, the packages should be **native** to the distribution e.g.
not to mix Debian package with Ubuntu and vice versa.   There may be
subtle artefacts (bugs) that show up on "out of the box" use cases.

-- Arun Khan


More information about the ilugc mailing list